const regex = /^0([1-9]{2})([1-9]{2})([2-3]{1})([0-9]{3})([0-9]{4})$|([1-9]{2})([8-9]{1})([0-9]{3})([0-9]{4})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0([1-9]{2})([1-9]{2})([2-3]{1})([0-9]{3})([0-9]{4})$|([1-9]{2})([8-9]{1})([0-9]{3})([0-9]{4})$', '')
const str = `7491260006`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);