$re = '/([a-z A-Z 0-9 À-ÿ]*).(?i)(\bpb\b|\bpbi\b)/';
$str = 'main.pbp';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);