const regex = /([a-z A-Z 0-9 À-ÿ]*).(?i)(\bpb\b|\bpbi\b)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z A-Z 0-9 À-ÿ]*).(?i)(\\bpb\\b|\\bpbi\\b)', '')
const str = `main.pbp`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}