using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z A-Z 0-9 À-ÿ]*).(?i)(\bpb\b|\bpbi\b)";
string input = @"main.pbp";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}