import Foundation
let pattern = #"^(?<tag>(?:[a-zA-Z]\w*|_\w+))(?<memspec>(?:(?:(?:\s*\.(?:[a-zA-Z]\w*|_\w+)|(?:\s*\[(?:[^,\]]+)(?:,(?:[^,\]]+))*\]))*)(?:(?:\s*\.\d+|\.\s*(?:\s*\[(?:[^,\]]+)\]))?)))?(?<metadataspec>(?:\s*\.\@(?<metadataid>(?:[a-zA-Z]\w*|_\w+))(?<metadatamemspec>(?:(?:(?:\s*\.(?:[a-zA-Z]\w*|_\w+)|(?:\s*\[(?:[^,\]]+)(?:,(?:[^,\]]+))*\]))*)(?:(?:\s*\.\d+|\.\s*(?:\s*\[(?:[^,\]]+)\]))?)))?))?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
tag
tag.mem
tag.1
tag.[0]
tag[0]
tag[0].mem
tag[0].1
tag[0].[0]
tag.mem
tag.mem.mem
tag.mem.1
tag.mem.[0]
tag.mem[0]
tag.mem[0].mem
tag.mem[0].1
tag.mem[0].[0]
tag.@foo.mem[0].[0]
tag.mem.@foo.mem[0].[0]
tag.1.@foo.mem[0].[0]
tag.[0].@foo.mem[0].[0]
tag[0].@foo.mem[0].[0]
tag[0].mem.@foo.mem[0].[0]
tag[0].1.@foo.mem[0].[0]
tag[0].[0].@foo.mem[0].[0]
tag.mem.@foo.mem[0].[0]
tag.mem.mem.@foo.mem[0].[0]
tag.mem.1.@foo.mem[0].[0]
tag.mem.[0].@foo.mem[0].[0]
tag.mem[0].@foo.mem[0].[0]
tag.mem[0].mem.@foo.mem[0].[0]
tag.mem[0].1.@foo.mem[0].[0]
tag.mem[0].[0].@foo.mem[0].[0]
tag .mem [ tag.@foo ] .mem .@foo .mem [ 0 ] .a .1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)