# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<tag>(?:[a-zA-Z]\w*|_\w+))(?<memspec>(?:(?:(?:\s*\.(?:[a-zA-Z]\w*|_\w+)|(?:\s*\[(?:[^,\]]+)(?:,(?:[^,\]]+))*\]))*)(?:(?:\s*\.\d+|\.\s*(?:\s*\[(?:[^,\]]+)\]))?)))?(?<metadataspec>(?:\s*\.\@(?<metadataid>(?:[a-zA-Z]\w*|_\w+))(?<metadatamemspec>(?:(?:(?:\s*\.(?:[a-zA-Z]\w*|_\w+)|(?:\s*\[(?:[^,\]]+)(?:,(?:[^,\]]+))*\]))*)(?:(?:\s*\.\d+|\.\s*(?:\s*\[(?:[^,\]]+)\]))?)))?))?$"
test_str = ("tag\n"
"tag.mem\n"
"tag.1\n"
"tag.[0]\n"
"tag[0]\n"
"tag[0].mem\n"
"tag[0].1\n"
"tag[0].[0]\n"
"tag.mem\n"
"tag.mem.mem\n"
"tag.mem.1\n"
"tag.mem.[0]\n"
"tag.mem[0]\n"
"tag.mem[0].mem\n"
"tag.mem[0].1\n"
"tag.mem[0].[0]\n\n"
"tag.@foo.mem[0].[0]\n"
"tag.mem.@foo.mem[0].[0]\n"
"tag.1.@foo.mem[0].[0]\n"
"tag.[0].@foo.mem[0].[0]\n"
"tag[0].@foo.mem[0].[0]\n"
"tag[0].mem.@foo.mem[0].[0]\n"
"tag[0].1.@foo.mem[0].[0]\n"
"tag[0].[0].@foo.mem[0].[0]\n"
"tag.mem.@foo.mem[0].[0]\n"
"tag.mem.mem.@foo.mem[0].[0]\n"
"tag.mem.1.@foo.mem[0].[0]\n"
"tag.mem.[0].@foo.mem[0].[0]\n"
"tag.mem[0].@foo.mem[0].[0]\n"
"tag.mem[0].mem.@foo.mem[0].[0]\n"
"tag.mem[0].1.@foo.mem[0].[0]\n"
"tag.mem[0].[0].@foo.mem[0].[0]\n\n\n"
"tag .mem [ tag.@foo ] .mem .@foo .mem [ 0 ] .a .1\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.