#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<tag>(?:[a-zA-Z]\w*|_\w+))(?<memspec>(?:(?:(?:\s*\.(?:[a-zA-Z]\w*|_\w+)|(?:\s*\[(?:[^,\]]+)(?:,(?:[^,\]]+))*\]))*)(?:(?:\s*\.\d+|\.\s*(?:\s*\[(?:[^,\]]+)\]))?)))?(?<metadataspec>(?:\s*\.\@(?<metadataid>(?:[a-zA-Z]\w*|_\w+))(?<metadatamemspec>(?:(?:(?:\s*\.(?:[a-zA-Z]\w*|_\w+)|(?:\s*\[(?:[^,\]]+)(?:,(?:[^,\]]+))*\]))*)(?:(?:\s*\.\d+|\.\s*(?:\s*\[(?:[^,\]]+)\]))?)))?))?$"
Local $sString = "tag" & @CRLF & _
"tag.mem" & @CRLF & _
"tag.1" & @CRLF & _
"tag.[0]" & @CRLF & _
"tag[0]" & @CRLF & _
"tag[0].mem" & @CRLF & _
"tag[0].1" & @CRLF & _
"tag[0].[0]" & @CRLF & _
"tag.mem" & @CRLF & _
"tag.mem.mem" & @CRLF & _
"tag.mem.1" & @CRLF & _
"tag.mem.[0]" & @CRLF & _
"tag.mem[0]" & @CRLF & _
"tag.mem[0].mem" & @CRLF & _
"tag.mem[0].1" & @CRLF & _
"tag.mem[0].[0]" & @CRLF & _
"" & @CRLF & _
"tag.@foo.mem[0].[0]" & @CRLF & _
"tag.mem.@foo.mem[0].[0]" & @CRLF & _
"tag.1.@foo.mem[0].[0]" & @CRLF & _
"tag.[0].@foo.mem[0].[0]" & @CRLF & _
"tag[0].@foo.mem[0].[0]" & @CRLF & _
"tag[0].mem.@foo.mem[0].[0]" & @CRLF & _
"tag[0].1.@foo.mem[0].[0]" & @CRLF & _
"tag[0].[0].@foo.mem[0].[0]" & @CRLF & _
"tag.mem.@foo.mem[0].[0]" & @CRLF & _
"tag.mem.mem.@foo.mem[0].[0]" & @CRLF & _
"tag.mem.1.@foo.mem[0].[0]" & @CRLF & _
"tag.mem.[0].@foo.mem[0].[0]" & @CRLF & _
"tag.mem[0].@foo.mem[0].[0]" & @CRLF & _
"tag.mem[0].mem.@foo.mem[0].[0]" & @CRLF & _
"tag.mem[0].1.@foo.mem[0].[0]" & @CRLF & _
"tag.mem[0].[0].@foo.mem[0].[0]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"tag .mem [ tag.@foo ] .mem .@foo .mem [ 0 ] .a .1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")