re = /(?<=>)([\w\s]+)(?=<\/)/m
str = '<table>
<tr><td>Cell 1</td><td>Cell 2</td><td>Cell 3</td></tr>
<tr><td>Cell 4</td><td>Cell 5</td><td>Cell 6</td></tr>
</table>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end