import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=>)([\\w\\s]+)(?=</)";
final String string = "<table>\n"
+ "<tr><td>Cell 1</td><td>Cell 2</td><td>Cell 3</td></tr>\n"
+ "<tr><td>Cell 4</td><td>Cell 5</td><td>Cell 6</td></tr>\n"
+ "</table>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}