#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=>)([\w\s]+)(?=</)"
Local $sString = "<table>" & @CRLF & _
"<tr><td>Cell 1</td><td>Cell 2</td><td>Cell 3</td></tr>" & @CRLF & _
"<tr><td>Cell 4</td><td>Cell 5</td><td>Cell 6</td></tr>" & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")