re = /data\/(.+)\/(.+)(?=\&)&?(.+)/
str = 'data/my.data/10&abc=10
data/my.data/10/&abc=10
data/my.data/10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end