$re = '/data\/(.+)\/(.+)(?=\&)&?(.+)/';
$str = 'data/my.data/10&abc=10
data/my.data/10/&abc=10
data/my.data/10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);