using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"data\/(.+)\/(.+)(?=\&)&?(.+)";
string input = @"data/my.data/10&abc=10
data/my.data/10/&abc=10
data/my.data/10";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}