re = /^https?:\/\/((w{3}\.)|(w{0}))\w+\.[a-z]{2,6}\/([\S]+)/i
str = 'https://www.tiki.vn/dien-thoai-may-tinh-bang/c1789?src=mega-menu '
# Print the match result
str.match(re) do |match|
puts match.to_s
end