const regex = /^https?:\/\/((w{3}\.)|(w{0}))\w+\.[a-z]{2,6}\/([\S]+)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/((w{3}\\.)|(w{0}))\\w+\\.[a-z]{2,6}\\\/([\\S]+)', 'i')
const str = `https://www.tiki.vn/dien-thoai-may-tinh-bang/c1789?src=mega-menu `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}