$re = '/^https?:\/\/((w{3}\.)|(w{0}))\w+\.[a-z]{2,6}\/([\S]+)/i';
$str = 'https://www.tiki.vn/dien-thoai-may-tinh-bang/c1789?src=mega-menu ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);