re = /\.(?=.+\..+$)/m
str = 'Photo-de-M.-RIES-.Hôtel-de-Ville-2018_.Snapseed.jpg
Attention ça nique la double extension :
Photo-de-M.-RIES-.Hôtel-de-Ville-2018_.Snapseed.jpg.zip
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end