using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(?=.+\..+$)";
string input = @"Photo-de-M.-RIES-.Hôtel-de-Ville-2018_.Snapseed.jpg
Attention ça nique la double extension :
Photo-de-M.-RIES-.Hôtel-de-Ville-2018_.Snapseed.jpg.zip
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}