$re = '/\.(?=.+\..+$)/m';
$str = 'Photo-de-M.-RIES-.Hôtel-de-Ville-2018_.Snapseed.jpg
Attention ça nique la double extension :
Photo-de-M.-RIES-.Hôtel-de-Ville-2018_.Snapseed.jpg.zip
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);