# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\+91[\s-]\d{5}[\s-]\d{5})|(011[\s-]\d{8})|(\+91\d{2}[\s-]\d{8})|(^0\d{10})|(^[6-9]\d{9})|(91[\s-]\d{3,5}[\s-]\d{2,5}[\s-]\d{4})|(91[\s-]\d{5}[\s-]\d{5})|(91[\s-]\d{10})|(\d{4}[\s-]\d{4}[\s-]\d{3})"
test_str = ("r1: (\\+91[\\s-]\\d{5}[\\s-]\\d{5})|(011[\\s-]\\d{8})|(\\+91\\d{2}[\\s-]\\d{8})|(^0\\d{10})|(^[6-9]\\d{9})|(91[\\s-]\\d{3,5}[\\s-]\\d{3,5}[\\s-]\\d{4})|(91[\\s-]\\d{5}[\\s-]\\d{5})|(91[\\s-]\\d{10})\n"
"+91-98600 27066 / \n"
"+91-73871 11066\n"
"011-29534999, 011-29532555, 011 47527999\n"
"+9133 24798066,\n"
"+9133 24483458/3459\n"
"08048620522\n"
"8046041848\n"
"91 124 392 3000\n"
"91-80884 00951\n"
"91-9821328595\n"
"91 9822015432\n"
"+91 033 2461 8212 \n"
"+91 033 2461 8213\n\n\n"
"645+91-98600 270664684 / \n"
"6546+91-73871 11066656\n"
"011-29534999, 011-29532555, 011 47527999\n"
"+9133 24798066656,\n"
"+9133 24483458/3459\n"
"8048620522656\n"
"8046041848656\n"
"91 124 392 3000656\n"
"91-80884 00951656\n"
"91-9821328595656656\n"
"91 9822015432656\n"
"656+91 033 2461 8212 \n"
"+91 033 2461 8213656\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.