#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\+91[\s-]\d{5}[\s-]\d{5})|(011[\s-]\d{8})|(\+91\d{2}[\s-]\d{8})|(^0\d{10})|(^[6-9]\d{9})|(91[\s-]\d{3,5}[\s-]\d{2,5}[\s-]\d{4})|(91[\s-]\d{5}[\s-]\d{5})|(91[\s-]\d{10})|(\d{4}[\s-]\d{4}[\s-]\d{3})"
Local $sString = "r1: (\+91[\s-]\d{5}[\s-]\d{5})|(011[\s-]\d{8})|(\+91\d{2}[\s-]\d{8})|(^0\d{10})|(^[6-9]\d{9})|(91[\s-]\d{3,5}[\s-]\d{3,5}[\s-]\d{4})|(91[\s-]\d{5}[\s-]\d{5})|(91[\s-]\d{10})" & @CRLF & _
"+91-98600 27066 / " & @CRLF & _
"+91-73871 11066" & @CRLF & _
"011-29534999, 011-29532555, 011 47527999" & @CRLF & _
"+9133 24798066," & @CRLF & _
"+9133 24483458/3459" & @CRLF & _
"08048620522" & @CRLF & _
"8046041848" & @CRLF & _
"91 124 392 3000" & @CRLF & _
"91-80884 00951" & @CRLF & _
"91-9821328595" & @CRLF & _
"91 9822015432" & @CRLF & _
"+91 033 2461 8212 " & @CRLF & _
"+91 033 2461 8213" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"645+91-98600 270664684 / " & @CRLF & _
"6546+91-73871 11066656" & @CRLF & _
"011-29534999, 011-29532555, 011 47527999" & @CRLF & _
"+9133 24798066656," & @CRLF & _
"+9133 24483458/3459" & @CRLF & _
"8048620522656" & @CRLF & _
"8046041848656" & @CRLF & _
"91 124 392 3000656" & @CRLF & _
"91-80884 00951656" & @CRLF & _
"91-9821328595656656" & @CRLF & _
"91 9822015432656" & @CRLF & _
"656+91 033 2461 8212 " & @CRLF & _
"+91 033 2461 8213656" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")