import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\+91[\\s-]\\d{5}[\\s-]\\d{5})|(011[\\s-]\\d{8})|(\\+91\\d{2}[\\s-]\\d{8})|(^0\\d{10})|(^[6-9]\\d{9})|(91[\\s-]\\d{3,5}[\\s-]\\d{2,5}[\\s-]\\d{4})|(91[\\s-]\\d{5}[\\s-]\\d{5})|(91[\\s-]\\d{10})|(\\d{4}[\\s-]\\d{4}[\\s-]\\d{3})";
final String string = "r1: (\\+91[\\s-]\\d{5}[\\s-]\\d{5})|(011[\\s-]\\d{8})|(\\+91\\d{2}[\\s-]\\d{8})|(^0\\d{10})|(^[6-9]\\d{9})|(91[\\s-]\\d{3,5}[\\s-]\\d{3,5}[\\s-]\\d{4})|(91[\\s-]\\d{5}[\\s-]\\d{5})|(91[\\s-]\\d{10})\n"
+ "+91-98600 27066 / \n"
+ "+91-73871 11066\n"
+ "011-29534999, 011-29532555, 011 47527999\n"
+ "+9133 24798066,\n"
+ "+9133 24483458/3459\n"
+ "08048620522\n"
+ "8046041848\n"
+ "91 124 392 3000\n"
+ "91-80884 00951\n"
+ "91-9821328595\n"
+ "91 9822015432\n"
+ "+91 033 2461 8212 \n"
+ "+91 033 2461 8213\n\n\n"
+ "645+91-98600 270664684 / \n"
+ "6546+91-73871 11066656\n"
+ "011-29534999, 011-29532555, 011 47527999\n"
+ "+9133 24798066656,\n"
+ "+9133 24483458/3459\n"
+ "8048620522656\n"
+ "8046041848656\n"
+ "91 124 392 3000656\n"
+ "91-80884 00951656\n"
+ "91-9821328595656656\n"
+ "91 9822015432656\n"
+ "656+91 033 2461 8212 \n"
+ "+91 033 2461 8213656\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}