re = /(?P<id>[a-zA-Z][\w\+\.\-\_]*)@(?P<domain>[\w\.\-\_]*[a-zA-Z])/
str = 'richie@cc.gatech.edu'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end