using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<id>[a-zA-Z][\w\+\.\-\_]*)@(?P<domain>[\w\.\-\_]*[a-zA-Z])";
string input = @"richie@cc.gatech.edu";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}