package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<id>[a-zA-Z][\w\+\.\-\_]*)@(?P<domain>[\w\.\-\_]*[a-zA-Z])`)
var str = `richie@cc.gatech.edu`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}