re = / (?=[^ ]+$)/m
str = 'Les hommes-grenouilles dans la rivière.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result