use strict;
my $str = 'Les hommes-grenouilles dans la rivière.';
my $regex = qr/ (?=[^ ]+$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";