$re = '/ (?=[^ ]+$)/m';
$str = 'Les hommes-grenouilles dans la rivière.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;