$re = '/\[\d{2}\.\d{2}\-\d{2}\:\d{2}\:\d{2}\.\d{3}\]/';
$str = '[18.10-04:00:46.660]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);