package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\d{2}\.\d{2}\-\d{2}\:\d{2}\:\d{2}\.\d{3}\]`)
var str = `[18.10-04:00:46.660]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}