using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\d{2}\.\d{2}\-\d{2}\:\d{2}\:\d{2}\.\d{3}\]";
string input = @"[18.10-04:00:46.660]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}