re = /^[1][0]\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.[0]\.[0]/
str = '10.25.0.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end