const regex = /^[1][0]\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.[0]\.[0]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[1][0]\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.[0]\\.[0]', 'g')
const str = `10.25.0.0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}