package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[1][0]\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.[0]\.[0]`)
var str = `10.25.0.0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}