import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?mx)\n"
+ "^(?:\\+\\d{1,2}\\ )?\n"
+ "\\(?\\d{3}\\)?\n"
+ "[\\ \\.-]\n"
+ "\\d{3}\n"
+ "[\\ \\.-]\n"
+ "\\d{4}";
final String string = "123-456-5555\n"
+ "(123) 222-1234\n"
+ "123 555 5555\n"
+ "123.777.7979\n"
+ "+91 (123) 455-6000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}