package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?mx)
^(?:\+\d{1,2}\ )?
\(?\d{3}\)?
[\ \.-]
\d{3}
[\ \.-]
\d{4}`)
var str = `123-456-5555
(123) 222-1234
123 555 5555
123.777.7979
+91 (123) 455-6000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}