using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?mx)
^(?:\+\d{1,2}\ )?
\(?\d{3}\)?
[\ \.-]
\d{3}
[\ \.-]
\d{4}";
string input = @"123-456-5555
(123) 222-1234
123 555 5555
123.777.7979
+91 (123) 455-6000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}