import Foundation
let pattern = #"^(\s+)(.*?) AS ([^,]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
column1 AS alias1,
column2 AS alias2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1'\3' => '\2'"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)