// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\s+)(.*?) AS ([^,]+)").unwrap();
let string = " column1 AS alias1,
column2 AS alias2";
let substitution = "\\1'\\3' => '\\2'";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}