$re = '/^(\s+)(.*?) AS ([^,]+)/m';
$str = ' column1 AS alias1,
column2 AS alias2';
$subst = "\1'\3' => '\2'";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;