re = /((?:\d,)+?)\1/m
str = '1,2,3,4,1,2,3,4,5,6,5,6,5,6,
2,3,1,2,3,1,1,2,3,4,
2,3,1,1,2,3,4,2,3,1,
1,2,3,1,2,3,1,2,3,1,2,3,
6,6,6,6,6,6,6,6,1,2,3,4,
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end