import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\d,)+?)\\1";
final String string = "1,2,3,4,1,2,3,4,5,6,5,6,5,6,\n"
+ "2,3,1,2,3,1,1,2,3,4,\n"
+ "2,3,1,1,2,3,4,2,3,1,\n"
+ "1,2,3,1,2,3,1,2,3,1,2,3,\n"
+ "6,6,6,6,6,6,6,6,1,2,3,4,\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}