using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\d,)+?)\1";
string input = @"1,2,3,4,1,2,3,4,5,6,5,6,5,6,
2,3,1,2,3,1,1,2,3,4,
2,3,1,1,2,3,4,2,3,1,
1,2,3,1,2,3,1,2,3,1,2,3,
6,6,6,6,6,6,6,6,1,2,3,4,
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}