// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{10}-\d{3}$").unwrap();
let string = "989891832213213
987-12-1234
12-2343244
123123--123
1234567890-123
1234476895-120";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}