package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{10}-\d{3}$`)
var str = `989891832213213
987-12-1234
12-2343244
123123--123
1234567890-123
1234476895-120`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}