re = /^\d{10}-\d{3}$/m
str = '989891832213213
987-12-1234
12-2343244
123123--123
1234567890-123
1234476895-120'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end