// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d*)((\/)\d*)? ([^ ]*) (Alley|Approach|Arcade|Avenue|Boardwalk|Boulevard|Break|Bypass|Chase|Circuit|Close|Concourse|Court|Crescent|Crest|Drive|Entrance|Esplanade|Firetrail|Freeway|Glade|Grange|Grove|Highway|Lane|Loop|Mall|Mews|Parade|Parkway|Passage|Path|Place|Plaza|Promenade|Quays|Ramp|Retreat|Ridge|Rise|Road|Square|Steps|Street|Subway|Terrace|Track|Trail|View|Vista|Walk|Way|Wharf)").unwrap();
let string = "1/7 Kieller Avenue";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}