const regex = /(\d*)((\/)\d*)? ([^ ]*) (Alley|Approach|Arcade|Avenue|Boardwalk|Boulevard|Break|Bypass|Chase|Circuit|Close|Concourse|Court|Crescent|Crest|Drive|Entrance|Esplanade|Firetrail|Freeway|Glade|Grange|Grove|Highway|Lane|Loop|Mall|Mews|Parade|Parkway|Passage|Path|Place|Plaza|Promenade|Quays|Ramp|Retreat|Ridge|Rise|Road|Square|Steps|Street|Subway|Terrace|Track|Trail|View|Vista|Walk|Way|Wharf)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d*)((\\\/)\\d*)? ([^ ]*) (Alley|Approach|Arcade|Avenue|Boardwalk|Boulevard|Break|Bypass|Chase|Circuit|Close|Concourse|Court|Crescent|Crest|Drive|Entrance|Esplanade|Firetrail|Freeway|Glade|Grange|Grove|Highway|Lane|Loop|Mall|Mews|Parade|Parkway|Passage|Path|Place|Plaza|Promenade|Quays|Ramp|Retreat|Ridge|Rise|Road|Square|Steps|Street|Subway|Terrace|Track|Trail|View|Vista|Walk|Way|Wharf)', 'gm')
const str = `1/7 Kieller Avenue`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}