package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d*)((\/)\d*)? ([^ ]*) (Alley|Approach|Arcade|Avenue|Boardwalk|Boulevard|Break|Bypass|Chase|Circuit|Close|Concourse|Court|Crescent|Crest|Drive|Entrance|Esplanade|Firetrail|Freeway|Glade|Grange|Grove|Highway|Lane|Loop|Mall|Mews|Parade|Parkway|Passage|Path|Place|Plaza|Promenade|Quays|Ramp|Retreat|Ridge|Rise|Road|Square|Steps|Street|Subway|Terrace|Track|Trail|View|Vista|Walk|Way|Wharf)`)
var str = `1/7 Kieller Avenue`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}