$re = '/\_\d(.+)/';
$str = '_Delivery_20150415162602.xml';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);